Mission Prefetch



  • Is there anything a server owner has to do to get the mission prefetch feature to work or will it automatically download it?


  • administrators



  • Can you only run one instance at a time? If I try running two, I get this:

    D:\servers\251_2302>missionprefetchserver 2302 D:\servers\251_2302\mpmissions\Ex
    ile.Tanoa.pbo 23.254.153.251 2303 5
    Running server on port 2309 | Serving pbo: D:\servers\251_2302\mpmissions\Exile.
    Tanoa.pbo
    Waiting for 5s before querying...
    Loading Pbo D:\servers\251_2302\mpmissions\Exile.Tanoa.pbo

    Unhandled Exception: System.Net.Sockets.SocketException: Only one usage of each
    socket address (protocol/network address/port) is normally permitted
    at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress
    socketAddress)
    at System.Net.Sockets.Socket.Bind(EndPoint localEP)
    at System.Net.Sockets.TcpListener.Start(Int32 backlog)
    at System.Net.Sockets.TcpListener.Start()
    at uhttpsharp.Listeners.TcpListenerAdapter..ctor(TcpListener listener) in c:
    Users\shani\Documents\GitHub\uHttpSharp\uhttpsharp\Listeners\TcpListenerAdapter.
    cs:line 14
    at MissionPrefetchServer.Program.Main(String[] args)


  • administrators

    You can only run it once per "server".
    The port on the second instance is wrong



  • @maca134 said in Mission Prefetch:

    You can only run it once per "server".
    The port on the second instance is wrong

    I have two servers on different IP's on the same dedicated box. They both use the same port (2302).

    I tested it by starting it on Chernarus, worked fine.
    Next I started it on Tanoa and i got the above error.

    After that I shut it down on Chernarus and started it on Tanoa first and it worked fine.
    Next I started it on Chernarus and I got the same type of error as above.


  • administrators

    Ahh i get it now. The exe "binds" to all ips on the box.

    I will release a new version, probably monday which will allow you to specify the ip address.



  • eta on new version?


  • administrators

    The update has been uploaded, please give that a try.


Log in to reply
 

Looks like your connection to Launcher Support Forum was lost, please wait while we try to reconnect.