Need folder names that A3Launcher wants to see. Nothing seems to work.



  • I had been running "PLP Urban Packs Barriers and Fences" and "Arma 3 Custom Buildings - Original" on A3 prior to the 1.68 update. It took a lot of trial and error to find a folder name on my server that A3Launcher would accept. Prior to the A3 1.68 update I had them working but had to try many, many folder names before I stumbled on the exact combination that A3Launcher would accept.  And they had to have spaces in the folder names so I had to enclose my startup parameters with quotes.   But it did work.  But now with  1.68, A3Launcher no longer recognizes those folder names.   I've spent the last hour trying many different folder names but have yet to find one that works with the new Arma3 version.    I've renamed mod folders many, many times for years on four game servers and never had this issue except with these two mods.

    Can anyone, anyone at all, tell me the folder names that A3Launcher wants to see on the server?


  • administrators

    The mod.cpp is the most important file when detecting running mods.
    ARMA only uses the folder name when there is no mod.cpp/meta.cpp.

    If you make sure you upload all mod files, it should be fine. It not then there is probably something else going on.



  • Well, "PLP Urban Packs Barriers and Fences" has a meta.cpp but no mod.cpp. Here's the relevant line directly from meta.cpp:

    name = "PLP Urban Packs: Barriers and Fences";

    Problem is that the colon is an invalid character for a Windows folder name. I tried without the colon and also with an underscore, but neither worked with A3Launcher, So in that case, what would I use for a folder name? The actual mod name on A3Launcher also has the colon in it. I even tried the Steam publshedID as a folder name. And I tried the PBO name (plp_urban_barriers).

    As to the "Arma 3 Custom Buildings - Original", it has both the meta.cpp and mod.cpp. Meta.cpp has:

    name = "ArmA 3 Custom Buildings";

    while mod.cpp has:

    name = "Mattaust Buildings Pack"; and dir = "@MattaustBuildings"; in it.

    None of those work. I tried all three.

    But when I launch from Steam, it loads fine. I see it in the table of loaded mods in my client-side .RPT and the objects are on the map. Likewise if I load my mission.sqm with the 3den editor.

    I'm at a loss as to what to do next. Seems there's nothing else I can do from my end unless A3Launcher is looking for something totally different.



  • So no help? No thoughts? I saw previous threads where something had to be done on the A3Launcher server itself in order for people's clients to actually find it. I've done everything I can from my end. Seems the issue is on the other end. Maybe the meta.cpp or mod.cpp files are not created to the necessary standards and conventions? Even so, that could only be changed on the server side where the mods are initially retrieved from (A3Launcher).



  • @maca134 Same for me .. I used all the files in all 3 packs .. as I just posted .. none work any longer



  • There is no mod.cpp only meta.cpp in all three PLP mods thats why not working possibly, but its working fine in the built in arma 3 launcher



  • What's odd is that if I use @PLP Containers; and @PLP Beach Objects; in my startup:

    SET ADDINS="@Kerama;@Exile;@OCP;@CUP_Terrains;@BG_Slaughterhouse;@CBA_A3;@CUP_Terrains_CWA;@CUP_Terrains_Maps;@Respirator;@PLP Beach Objects;@PLP Containers;@Extended_Items_Exile;"

    and leave the space in and enclose the entire ADDINS string in quotes, that works. But I could not find any folder name that would work for the Arma3 Custom Buildings or the PLP Urban Packs Barriers and Fences addons .


Log in to reply
 

Looks like your connection to Launcher Support Forum was lost, please wait while we try to reconnect.