Arma3 Custom Buildings - Original returns "unknown mod" but it's on A3L

  • This is the part of my batch file that does the startup. Note that it works totally fine and has for a long time without the custom buildings. As soon as I add @Custom_Bldgs; to the end and restart my server, the server drops off the server list in A3Launcher and I get Oh snap! unknown mods - Mattaust Buildings Pack when I check server. As soon as I do no more than delete @Custom_Bldgs; from the end and restart the server, my server reappears on A3L. So I'll be very surprised if it has anything to do with my startup parameters. Besides I'm running three other servers with the same startup (except for the map and a few other addins - no others are running the Custom Buildings though) and they all have worked for a long time now.

    SET [email protected];@Exile;@OCP;@CUP_Terrains;@BG_Slaughterhouse;@CBA_A3;@CUP_Terrains_CWA;@CUP_Terrains_Maps;@Respirator;@Custom_Bldgs;
    start "Arma3E" /min /wait E:\Arma3\Kerama\arma3server.exe [email protected];@marma; -mod=%addins% -config=E:\Arma3\[email protected]\config.cfg -port=2332 -profiles=SC -cfg=E:\Arma3\[email protected]\basic.cfg -name=SC -autoinit

  • I should also note that I update the keys every time I try a different way to install the mod. Could it be related to mod.cpp? I did find this link - but don't exactly know how to use this information. Although s different mod, they had the same problem.

  • I'm now also getting the same thing with all the PLP mods (Urban and fences, containers, beach items). They come up fine with the editor and 3DEN or if I launch with the Arma/Steam launcher. What actually causes a valid mod to be "unrecognized"? I've tried re-downloading multiple times and that doesn't generally help. Anything else I can provide? I'm anxious to start customization of my servers but need these mods.

  • So I'm playing around with the folder names. If the folder is named @PLP_Beaches, A3Launcher says it's an unrecognized mod. But if I name it @PLPBeaches, A3Launcher seems to see it fine. Problem is that I haven't actually put any objects from the mod on my server. I'm unwilling to do so until I can actually get the mods loading properly. But in my server.RPT, although @PLPBeaches seems to load OK, in the list of mods, @PLPBeaches has "NOT FOUND" in the origin column. So did it really load?

  • Well I had it working. But then with the latest A3 version, A3Launcher no longer recognizes it again. The first time, for whatever reason, A3Launcher seems to be incredibly particular about the name of the mod and the folder name on the server, but I did find a folder name that actually worked. I guess I have to start the process all over again.

  • Did you rename the folder? Does the mod have a mod.cpp in the root folder.

  • @maca134 no mod.cpp in any of the PLP mods

  • ive tweaked the mod detection. Tested it on your server, it looks good.

  • Thanks! I'll give it a go later today!

  • Everything's working great. Thanks!