Cant Stream when using A3Launcher



  • Hi Guys,

    I am trying to set up my stream with OBS but for some reason it wont work, I am getting a black screen but I am getting sound.

    Now when I put in -NOLAUNCH in the steam and launch through steam it works fine. Although if I do that then it wont let me join the server I want as the mods are not detected for some off reason.

    odd...very odd

    Do you guys have any idea how I can get it to work?



  • hey

    Weird problem, did you double check that it is A3 launcher?

    Try loading up the game through Arma3 launcher joining the same server & check that you can stream.

    cheers.



  • Hi @aussie

    It seems to be when launching Arma 3 though any launcher that it doesnt work. Which is why the fix -NOLAUNCHER works when put in steam. But naturally without the A3Launcher and all its glory, I cannot connect to the servers with mods on them, So I am a little confused.

    I have also tried the sister launcher CCG [i think thats its name] and it just seems that OBS ignores the game because the launcher doesnt seem to want to be picked up.

    I have tried turning off the "game compatibility hook" with the game capture. There is only one way that I can get it to capture the screen, and that is if i do a complete display capture of the game, however because of the way it captures the screen, it outputs at less than 1 fps haha! All the fun!

    Thanks.



  • Hey guys,

    Having the same issue...

    I did have an idea though, which I will try tonight:

    Load up Arma3 through Steam. Make sure that OBS is picking up the feed.
    Then Alt+Tab out and try to connect to the server I want via A3Launcher.

    I will come back and report on my findings.



  • So Ive tested this quite a bit and it doesnt seem to stream at all with OBS, yet when I launched with xsplit running it picked it up without an issue. However I dont want to use xsplit as its a fremium product...and I really like OBS

    Anyone got any ideas?



  • I fixed it...copied all of the mods into the arma3 folder :)


Log in to reply