"A3Launcher has stopped working" - wont launch

  • Kind of a 3 part problem, not sure exactly whats going on, ill try to provide as much info as possible.

    1. After not playing Arma for months, i launched steam, massive update

    2. after update attempted to launch, launch failed
      2.5) Official launcher would not launch no errors, could launch arma directly via install folder > arma3battleye.exe

    3. was able to fix the official launcher by holding "ctrl+shift" while launching, this provided the safe-mode windows. i disabled "hardware acceleration" and left everything else the same

    1. A3L experience the same issue as #2, will not launch. gives popup > "A3Launcher has stopped working"

    with this info:
    Problem signature:
    Problem Event Name: APPCRASH
    Application Name: A3Launcher.exe
    Application Version:
    Application Timestamp: 5cf66d76
    Fault Module Name: KERNELBASE.dll
    Fault Module Version: 6.1.7601.17514
    Fault Module Timestamp: 4ce7bafa
    Exception Code: c06d007e
    Exception Offset: 0000b727
    OS Version: 6.1.7601.
    Locale ID: 1033
    Additional Information 1: 0a9e
    Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
    Additional Information 3: 0a9e
    Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

    i tried a clean install, nothing

    i tried updating my drivers, nothing (coincidentally, this broke my hdmi sound)

    tried uninstalling again, this time deleting the registry entry, restarting, reinstalling, restarting, again nothing