Optional Launch Parameters?

  • I have been attempting to play DayZ and have opted for DayZLaucher this time around (Prior to this i had used DayZ Commander). I have followed along with an installation guide to play Overpoch so i had installed Arma 2, Arma 2 DayZ Mod, Arma 2 OA, and the OA Obsolete Beta.

    After that i had downloaded DayZ 1.9.0, DayZ Epoch, and DayZ Overwatch 0.2.5. After that i had run each game above to the menu and exited to steam. I also added the launch parameters "[email protected];@DayZ_Epoch" to DayZLauncher.

    This is where my issue begins, whenever i click to join a server that is in white (other servers are yellow and i assume that is because of the mod versions or whatever mods the server is running) i get directed to steam and i get this pop-up

    If i am to click okay it runs the game and i can join the server to the lobby, but whilst downloading the mission file i am kicked.
    I have tried joining servers through Arma 2 OA and the DayZ Mod but the result is the same.
    There are also some occasions where i am joining certain servers and am met with a message telling me to delete certain files. I haven't tried deleting them but i have read that it doesn't work anyway.

    I have also read that certain expansions need to be enabled/disabled and i am not sure which of those would need to be.