Can't Claim Sever



  • Change -mod and -servermod to

    [email protected];@chernarusredux;@cup_terrain_core;@ds_houses;@cba_a3;@enhancedmovement;@extended_base;@rhsafru;@cup_units;@cup_vehicles;@cup_weapons;@ffaa;@rhsusaf; [email protected];@admintoolkitserver;

    The "" are breaking loading



  • @mgtdb It will not start correctly without the "" in the mod parameters. The semi colons terminate the command and the backslash escapes it.



  • Get that backslashes out of the -mod and -servermod section and everything is fine



  • Does not work with the follow command. Same issue.

    ./arma3server [email protected]/basic.cfg [email protected]/config.cfg -mod="@exile;@chernarusredux;@cup_terrain_core;@ds_houses;@cba_a3;@enhancedmovement;@extended_base;@rhsafru;@cup_units;@cup_vehicles;@cup_weapons;@ffaa;@rhsusaf;" -servermod="@exileserver;@admintoolkitserver;" -BEPath=/etc/steam/server/arma/exile -autoinit > stdout.log 2> stderr.log &


  • Holy shit ....... no semicolons or others! Just [email protected];@blablub;@hmmm;@andsoon
    And NOTHING on the end!



  • For the record,

    ./arma3server [email protected]/basic.cfg [email protected]/config.cfg [email protected];@chernarusredux;@cup_terrain_core;@ds_houses;@cba_a3;@enhancedmovement;@extended_base;@rhsafru;@cup_units;@cup_vehicles;@cup_weapons;@ffaa;@rhsusaf [email protected];@admintoolkitserver -BEPath=/etc/steam/server/arma/exile -autoinit > stdout.log 2> stderr.log &
    

    Does not work at all. The semi colons terminate the command so it is read up to @exile and then nothing else. I either need to use backslashes to escape the semi colon or use quotes so it is read properly.



  • I am also getting this error if I run the server without ANY mods at all.

    ./arma3server
    


  • Just for the record ........ your server is a sponsor server? If not, you can´t claim it.



  • Not a sponsored server, however I receive the same error when I try to do the server check as well...



  • @schmurda said in Can't Claim Sever:

    52.144.35.226:2303

    try changing the order of mods? or reducing the amounts your running. see if that makes a difference



  • @maca134 I've tried running with just the exile client/server mods running which didn't work.

    I also tried a fresh install of Arma running with no mods and I get the same error



  • I may have found the issue...

    Looks like I was missing the tacops folder in my arma 3 directory.

    I must have been under the impression this was a single player mod, however the server works with/without the tacops mod running on the server.



  • @schmurda said in Can't Claim Sever:

    I may have found the issue...

    Looks like I was missing the tacops folder in my arma 3 directory.

    I must have been under the impression this was a single player mod, however the server works with/without the tacops mod running on the server.

    Well, it worked until I moved exile to the arma 3 server folder. I receive the mod count error when the "@exile" folder is in the actual arma 3 server folder, but the server actually starts. If I try to move the mod somewhere else the server check can read my server fine, however the mission won't start because it can't find the mod for some reason.



  • What a battle...

    So my server is showing up on the launcher now AND the mods are actually showing. This is a huge improvement from where I stood a week ago and I would like to point out a few things I did that ended up allowing the server to start and be seen by A3Launcher when running on a Linux server (ubuntu 16.04 specifically).

    • Starting with a fresh install, I used symlinks to a sibling directory of my Arma 3 install to make updating easier. This is optional, but will probably help in the long run
      • Ommit the "keys", "battleye", and "mpmissions" directory if going this route. Also, copy the arma3server file rather than linking it.
    • I have read that linux servers require the mod names be lowercase, however using the standard camel case naming worked for me. For consistency, I recommend you do the same.
    • In your start command, do not use any quotations. Instead, use a backslash before the semi-colon to prevent it from terminating the command before it is supposed to. This is my example start command that worked for me.
      • ./arma3server [email protected]/basic.cfg [email protected]/config.cfg -autoinit [email protected]\; [email protected]\; >> serverlog.rpt

      • I'm not sure if the order of options in the start command is important, however the server could not be queried by a3launcher when the -autoinit was after the -mod and -servermod options. For consistency, I would recommend you keep them in this order.

    • As always, make sure your ports are open on your router, and if you are using iptables on your machine, you can open the ports with the following command
      • iptables -I INPUT 1 -p tcp -m multiport --dports 2300:2310 -j ACCEPT

      • This will open ports 2300 to 2310 on your machine and insert this as the first rule in your chain. If you have a more complex setup, you may want to adjust these to your configuration.

    If anyone else has issues running an arma server on linux, I'd be more than happy to assist.

    If anyone notices something blatantly wrong in this post, please correct me. I'm no expert on arma server hosting but I'm learning the ropes.


 

true